SQL Developer - The Universal Database Frontend

Download

Getting the Software

Requirements

Java - Get It Now
  1. SQL Developer requires Java 1.4.2 or higher to be installed.
    Java 1.5.x is recommended.
    You can download the latest Java Runtime Environment from Sun's Java site.
    Mac OS X users can download the software directly from Apple.
  2. To connect to your database you also need the appropriate JDBC driver.
    See Drivers.

User Manual

Get Adobe Reader

The user manual is provided in English and German.

NOTE: You need the Adobe Reader or a compatible PDF viewer to open the
manual. Click the download button on the right to get Adobe Reader.


Application

The application is provided with English and German user interface.

It can be downloaded in ZIP or TAR/GZ format. Choose the best matching format for your platform.

Installation

SQL Developer comes without an installer. Just unpack the downloaded archive to your harddrive and start the application as described below:

Windows Windows

Double-click sqldeveloper.exe

Solaris Solaris

After downloading open a shell and change to the directory where you unpacked the downloaded archive.
At the prompt type: sqldeveloper.sh or sh sqldeveloper.sh

Linux Linux

After downloading open a shell,change to the directory where you unpacked the downloaded archive.
At the prompt type: sqldeveloper.sh or sh sqldeveloper.sh

Mac OS X Mac OS X

After downloading, double-click sqldeveloper.jar

Java Other Java Platforms

After downloading open a shell and change to the directory where you unpacked the downloaded archive.
At the prompt type: java -jar sqldeveloper.jar

Archive

Note: If you are looking for older releases of SQL Developer please use our archive.

To activate one of the older versions of SQL Developer please use the public license key below:

3q36zgAAACIAAAACAAAAAAAAARa8aDOTAAADuyyM

6YAAAQAGUHVibGljAAAALjAsAhRjhvTOVTKZvMpB

6IXlCivU0z14bAIUNFwY4DNqEfaoWC/oWmR7q8+H

obA=